6 of 24
6
CCV 1.4.1a Multicamera Preview - Call for Participation
Posted: 30 April 2011 09:30 AM   [ Ignore ]   [ # 76 ]
Avatar
RankRankRank
Joined  2010-01-15
Total Posts:  419
Sr. Member

Seeacloud, for what it’s worth, I’m getting the same problem here. 

I’ve got two ps3 cams GUID is correct on each config, cam height is set to 320x240 with an overall height of 640x240 and I’ve tried frame rates of 30, 60, 90, and 120 to no avail.  CCV loads up with (win7pro 64bit):

Community Core Vision > “Community Core Vision.exe”

***** VIDEOINPUT LIBRARY - 0.1995 - TFW07 *****

TreeIdMap loaded succesfully from ‘data/all.trees’.
Calibration is setup!

Camera(s)/Video Initialised…
Starting in standalone mode…

Starting in full mode…

Then it drops out and fails.

Each camera config tests perfectly individually.

My configs are as follows:

<?xml version="1.0" ?>
<CONFIG>
    <!--
/////////////////////////////////////////

        
YOU CAN MANUALLY EDIT THE FEATURES BELOW
 
    
///////////////////////////////////////////// -->
    
<!--// CAMERA SETTINGS // -->
    
<CAMERA_0>
        <
USECAMERA>1</USECAMERA>
        <
DEVICE>0</DEVICE>
        <
WIDTH>640</WIDTH>
        <
HEIGHT>240</HEIGHT>
        <
FRAMERATE>60</FRAMERATE>
    </
CAMERA_0>
    <!--
// NETWORK COMMUNICATION SETTINGS //-->
    
<NETWORK>
        <
LOCALHOST>127.0.0.1</LOCALHOST>
        <
TUIO>0</TUIO>
        <
TUIOPORT_OUT>3333</TUIOPORT_OUT>
        <
TUIOFLASHPORT_OUT>3000</TUIOFLASHPORT_OUT>
    </
NETWORK>
    <!--
// VIDEO SETTINGS // -->
    
<VIDEO>
        <
FILENAME>test_videos/RearDI.m4v</FILENAME>
    </
VIDEO>
    <!--
// BLOB SETTINGS // -->
    
<BLOBS>
        <
MAXNUMBER>100</MAXNUMBER>
    </
BLOBS>
    <!--
/////////////////////////////////////////

        
DO NOT EDIT THE VALUES BELOW
 
    
///////////////////////////////////////////// -->
    
<APPLICATION>
        <
TITLE>Community Core Visision</TITLE>
        <
VERSION>1.3.1</VERSION>
    </
APPLICATION>
    <
WINDOW>
        <
WIDTH>950</WIDTH>
        <
HEIGHT>600</HEIGHT>
    </
WINDOW>
    <
BOOLEAN>
        <
PRESSURE>0</PRESSURE>
        <
LABELS>1</LABELS>
        <
OUTLINES>0</OUTLINES>
        <
LEARNBG>0</LEARNBG>
        <
TUIO>0</TUIO>
        <
VMIRROR>0</VMIRROR>
        <
HMIRROR>0</HMIRROR>
        <
HIGHPASS>0</HIGHPASS>
        <
AMPLIFY>0</AMPLIFY>
        <
SMOOTH>0</SMOOTH>
        <
GPU>0</GPU>
        <
DYNAMICBG>0</DYNAMICBG>
        <
SNAPSHOT>0</SNAPSHOT>
        <
MINIMODE>0</MINIMODE>
        <
HEIGHTWIDTH>0</HEIGHTWIDTH>
        <
OSCMODE>0</OSCMODE>
        <
TCPMODE>0</TCPMODE>
        <
BINMODE>0</BINMODE>
        <
TRACKDARK>0</TRACKDARK>
        <
TRACKFINGERS>1</TRACKFINGERS>
        <
TRACKOBJECTS>0</TRACKOBJECTS>
        <
TRACKFIDUCIALS>0</TRACKFIDUCIALS>
        <
UNDISTORT>0</UNDISTORT>
        <
HORIZONTALINVERSE>1</HORIZONTALINVERSE>
        <
VERTICALINVERSE>1</VERTICALINVERSE>
    </
BOOLEAN>
    <
INT>
        <
MINMOVEMENT>0</MINMOVEMENT>
        <
MINBLOBSIZE>1</MINBLOBSIZE>
        <
MAXBLOBSIZE>100</MAXBLOBSIZE>
        <
BGLEARNRATE>19.145454</BGLEARNRATE>
        <
THRESHOLD>21</THRESHOLD>
        <
HIGHPASSBLUR>43</HIGHPASSBLUR>
        <
HIGHPASSNOISE>0</HIGHPASSNOISE>
        <
HIGHPASSAMP>300</HIGHPASSAMP>
        <
SMOOTH>0</SMOOTH>
        <
MINTEMPAREA>0</MINTEMPAREA>
        <
MAXTEMPAREA>0</MAXTEMPAREA>
    </
INT>
    <
FIDUCIAL>
        <
HIGHPASS>0</HIGHPASS>
        <
AMPLIFY>0</AMPLIFY>
        <
SMOOTH>0</SMOOTH>
        <
THRESHOLD>69</THRESHOLD>
        <
HIGHPASSBLUR>0</HIGHPASSBLUR>
        <
HIGHPASSNOISE>0</HIGHPASSNOISE>
        <
HIGHPASSAMP>0</HIGHPASSAMP>
        <
SMOOTHVALUE>5</SMOOTHVALUE>
    </
FIDUCIAL>
</
CONFIG>

<CAMERASETTINGS>
    <
GENERALSETTINGS>
        <
INTERLEAVE>1</INTERLEAVE>
        <
STITCHEDFRAMEWIDTH>640</STITCHEDFRAMEWIDTH>
        <
STITCHEDFRAMEHEIGHT>240</STITCHEDFRAMEHEIGHT>
        <
CALIBRATIONGRIDWIDTH>4</CALIBRATIONGRIDWIDTH>
        <
CALIBRATIONGRIDHEIGHT>3</CALIBRATIONGRIDHEIGHT>
        <
GPUMODE>0</GPUMODE>
        <
FRAMERATE>60</FRAMERATE>
        <
CAMERAGRIDWIDTH>2</CAMERAGRIDWIDTH>
        <
CAMERAGRIDHEIGHT>1</CAMERAGRIDHEIGHT>
        <
CAMERATYPE>0</CAMERATYPE>
    </
GENERALSETTINGS>             
   <
CAMERA>
        <
SETTINGS>        
            <
GUID>{7B4DB73B-41E3-1499-E071-FAB59D4580A7}</GUID>
            <
WIDTH>320</WIDTH>
            <
HEIGHT>240</HEIGHT>
            <
LEFT>0</LEFT>
            <
TOP>0</TOP>
            <
DEPTH>1</DEPTH>
            <
EXPOSURE>511</EXPOSURE>
            <
GAIN>40</GAIN>
        </
SETTINGS>
        <
POINTARRAY></POINTARRAY>
    </
CAMERA> <!--      -->
    <
CAMERA>
        <
SETTINGS>        
            <
GUID>{6A43136E-9940-87E3-B7B0-3B0B84518E3A}</GUID>
            <
WIDTH>320</WIDTH>
            <
HEIGHT>240</HEIGHT>
            <
LEFT>0</LEFT>
            <
TOP>0</TOP>
            <
DEPTH>1</DEPTH>
            <
EXPOSURE>511</EXPOSURE>
            <
GAIN>40</GAIN>
          </
SETTINGS>
          <
POINTARRAY></POINTARRAY>
    </
CAMERA>    
</
CAMERASETTINGS>

 Signature 

Personal MT Blog
Mesa Mundi Inc. and Online Store

Profile
 
 
Posted: 30 April 2011 09:31 AM   [ Ignore ]   [ # 77 ]
RankRank
Joined  2010-02-06
Total Posts:  173
Member

Ahhhh its a laptop. I think that your USB bus may be overloaded or your laptop is not fast enough. Try a different PC and let me know how it works.  Good luck.

 Signature 

Screwfunk
TouchMi inc. - 2 meter Prototype RearDI Bar

Profile
 
 
Posted: 30 April 2011 09:35 AM   [ Ignore ]   [ # 78 ]
Avatar
RankRankRank
Joined  2010-01-15
Total Posts:  419
Sr. Member

@Screwfunk:  Unlike Seeacloud, my setup is an i7-920 desktop with 4 usb devices attached, 1 mouse, 1 keyboard, 2 ps3 cams.

 Signature 

Personal MT Blog
Mesa Mundi Inc. and Online Store

Profile
 
 
Posted: 30 April 2011 09:40 AM   [ Ignore ]   [ # 79 ]
Avatar
RankRankRank
Joined  2010-01-15
Total Posts:  419
Sr. Member

Found the error:

INTERLEAVE should have been set to 0 rather than 1!

<CAMERASETTINGS>
    <
GENERALSETTINGS>
        <
INTERLEAVE>0</INTERLEAVE>
        <
STITCHEDFRAMEWIDTH>640</STITCHEDFRAMEWIDTH>
        <
STITCHEDFRAMEHEIGHT>240</STITCHEDFRAMEHEIGHT>
        <
CALIBRATIONGRIDWIDTH>4</CALIBRATIONGRIDWIDTH>
        <
CALIBRATIONGRIDHEIGHT>3</CALIBRATIONGRIDHEIGHT>
        <
GPUMODE>0</GPUMODE>
        <
FRAMERATE>60</FRAMERATE>
        <
CAMERAGRIDWIDTH>2</CAMERAGRIDWIDTH>
        <
CAMERAGRIDHEIGHT>1</CAMERAGRIDHEIGHT>
        <
CAMERATYPE>0</CAMERATYPE>
    </
GENERALSETTINGS>

 Signature 

Personal MT Blog
Mesa Mundi Inc. and Online Store

Profile
 
 
Posted: 30 April 2011 09:56 AM   [ Ignore ]   [ # 80 ]
RankRank
Joined  2008-09-25
Total Posts:  162
Member

that’s it!!!!!  the Interleave should be 0.

solved!! so happy!!!!!!

Thank you grimjack2600, Screwfunk and NUI Group!!

 Signature 

http://www.mt2a.com

Multi-touch Solution and Equipment Supplier!

Profile
 
 
Posted: 30 April 2011 10:53 AM   [ Ignore ]   [ # 81 ]
RankRank
Joined  2010-02-06
Total Posts:  173
Member

What resolution are you using and what FPS are you getting? I would bunp your resolution and frame rate back up to find your limit

 Signature 

Screwfunk
TouchMi inc. - 2 meter Prototype RearDI Bar

Profile
 
 
Posted: 30 April 2011 11:18 AM   [ Ignore ]   [ # 82 ]
Avatar
RankRankRank
Joined  2009-09-20
Total Posts:  263
Sr. Member

Hello guys!

I’m very happy that you have tested multicamera CCV.
As I said before - there are a lot specific in multicamera setups - I see that a lot of people who tried this beta had specific problems too. Remember - for high speed multicamera setup you need good usb hosts and pc.

I am going to release next beta bould this Wednesday.

In this thread I saw questions:
1)About @seeacloud problem with <VIDEOMODE>1</VIDEOMODE> - it’s a tag only for emulating camera work. You can use it only after recording some video from camera. For instructions -

If you haven’t recorded video from camera - set this tag to 0.
2)About @grimjack2600 and @seeacloud problem with INTERLEAVE mode - very surprised. Looking throught the sources for bug.
3)About perfomance - it’ll be increased in the next build. You can feel if you use multiple cameras in you setup only. For increasing perfomance - try to decrase total resolution. As i showed in this video

you can get VERY good result with low res capturing.

And last - report about bugs to me via PM.

Thanks for you participating in beta testing.

---
Best Regards, Anatoly Churikov

 Signature 

Microsoft Applied Sciences Group Intern

Profile
 
 
Posted: 30 April 2011 11:33 AM   [ Ignore ]   [ # 83 ]
Avatar
RankRankRank
Joined  2010-01-15
Total Posts:  419
Sr. Member

thanks again Anat!

This solves one of the big missing links in CCV.  Clean multi-cam support.
I’ll be trying this build with my non-ps3 cams in my DSI table this evening.  I’ll report on my success/failure with that build afterward.

 Signature 

Personal MT Blog
Mesa Mundi Inc. and Online Store

Profile
 
 
Posted: 30 April 2011 11:42 AM   [ Ignore ]   [ # 84 ]
Avatar
RankRankRank
Joined  2009-09-20
Total Posts:  263
Sr. Member

About fiducials - everything works great! If you have problems - PM me.

 Signature 

Microsoft Applied Sciences Group Intern

Profile
 
 
Posted: 30 April 2011 12:17 PM   [ Ignore ]   [ # 85 ]
Avatar
RankRankRank
Joined  2010-01-15
Total Posts:  419
Sr. Member

What size are the fids you are using?

I’m trying for 1” x 1” as a target size (2.54 centimeters)

Are you using endlighten T for your DSI effect? Or the older (thicker) XXL material?

In your other post you state that you’re using an LLP+DSI setup.  The laser sits above the whole thing, then is your stack setup as

LLP
rearprojection material
endlighten XXL/T

 Signature 

Personal MT Blog
Mesa Mundi Inc. and Online Store

Profile
 
 
Posted: 30 April 2011 12:27 PM   [ Ignore ]   [ # 86 ]
Avatar
RankRankRank
Joined  2009-09-20
Total Posts:  263
Sr. Member

@grimjack2600

I’ve tried LLP+DSI combination in the past. Now on videos you see DI. I’ve tried to use 2” x 2” fiducials. But with current filtering it works terrible - so i’ve done few experiments with it and now everything works fine. Wait for next beta release.

 Signature 

Microsoft Applied Sciences Group Intern

Profile
 
 
Posted: 30 April 2011 07:35 PM   [ Ignore ]   [ # 87 ]
RankRank
Joined  2008-09-25
Total Posts:  162
Member

Thank you Anat!!!! what you have done is amazing!!!!  thanks a lot!

 Signature 

http://www.mt2a.com

Multi-touch Solution and Equipment Supplier!

Profile
 
 
Posted: 01 May 2011 12:39 AM   [ Ignore ]   [ # 88 ]
RankRank
Joined  2010-02-06
Total Posts:  173
Member

Really amazing stuff ANAT… What projection material are you using Anat. Also what cameras are you using. You are getting some pretty impressive resolution.

Screwfunk

 Signature 

Screwfunk
TouchMi inc. - 2 meter Prototype RearDI Bar

Profile
 
 
Posted: 01 May 2011 01:57 AM   [ Ignore ]   [ # 89 ]
Avatar
RankRankRank
Joined  2009-09-20
Total Posts:  263
Sr. Member

@Screwfunk - as i said before - 7d006 and 4xPs3 Eye. Resolution is not very high - 640x360 but image - i agree is very good.

 Signature 

Microsoft Applied Sciences Group Intern

Profile
 
 
Posted: 04 May 2011 10:25 AM   [ Ignore ]   [ # 90 ]
RankRank
Joined  2008-09-25
Total Posts:  162
Member

crash with 4 ps3 eye,what’s wrong????????????????? I need some help. thanks!!!

camsetting:

<CAMERASETTINGS>
    <
GENERALSETTINGS>
        <
INTERLEAVE>0</INTERLEAVE>
        <
STITCHEDFRAMEWIDTH>320</STITCHEDFRAMEWIDTH>
        <
STITCHEDFRAMEHEIGHT>240</STITCHEDFRAMEHEIGHT>
        <
CALIBRATIONGRIDWIDTH>4</CALIBRATIONGRIDWIDTH>
        <
CALIBRATIONGRIDHEIGHT>3</CALIBRATIONGRIDHEIGHT>
        <
GPUMODE>0</GPUMODE>
        <
FRAMERATE>4</FRAMERATE>
        <
CAMERAGRIDWIDTH>2</CAMERAGRIDWIDTH>
        <
CAMERAGRIDHEIGHT>2</CAMERAGRIDHEIGHT>
        <
CAMERATYPE>0</CAMERATYPE>
    </
GENERALSETTINGS>    
    <
CAMERA>
        <
SETTINGS>
            <
GUID>{A01DAE1C-709E-AE66-72C3-7FB7E3E196EA}</GUID>
            <
WIDTH>160</WIDTH>
            <
HEIGHT>120</HEIGHT>
            <
LEFT>0</LEFT>
            <
TOP>0</TOP>
            <
DEPTH>1</DEPTH>
            <
EXPOSURE>200</EXPOSURE>
            <
GAIN>90</GAIN>
        </
SETTINGS>
        <
POINTARRAY></POINTARRAY>
    </
CAMERA>

     <
CAMERA>
        <
SETTINGS>
            <
GUID>{E2524558-4AA6-3A54-4EA3-C787FD8EC377}</GUID>
            <
WIDTH>160</WIDTH>
            <
HEIGHT>120</HEIGHT>
            <
LEFT>0</LEFT>
            <
TOP>0</TOP>
            <
DEPTH>1</DEPTH>
            <
EXPOSURE>200</EXPOSURE>
            <
GAIN>90</GAIN>
        </
SETTINGS>
        <
POINTARRAY></POINTARRAY>
    </
CAMERA>
    <
CAMERA>
        <
SETTINGS>
            <
GUID>{56A38F27-D872-962A-DF6D-A757D43F9988}</GUID>
            <
WIDTH>160</WIDTH>
            <
HEIGHT>120</HEIGHT>
            <
LEFT>0</LEFT>
            <
TOP>0</TOP>
            <
DEPTH>1</DEPTH>
            
            <
EXPOSURE>200</EXPOSURE>
            <
GAIN>90</GAIN>
        </
SETTINGS>
        <
POINTARRAY>
            
        </
POINTARRAY>
    </
CAMERA>
    <
CAMERA>
        <
SETTINGS>
            <
GUID>{7D0805BA-88D9-31E8-8C7E-19A13249AFD3}</GUID>
            <
WIDTH>160</WIDTH>
            <
HEIGHT>120</HEIGHT>
            <
LEFT>0</LEFT>
            <
TOP>0</TOP>
            <
DEPTH>1</DEPTH>
           
            <
EXPOSURE>200</EXPOSURE>
            <
GAIN>90</GAIN>
        </
SETTINGS>
        <
POINTARRAY>
            
        </
POINTARRAY>
    </
CAMERA>
</
CAMERASETTINGS>

config:

<?xml version="1.0" ?>
<CONFIG>
    <!--
/////////////////////////////////////////

        
YOU CAN MANUALLY EDIT THE FEATURES BELOW
 
    
///////////////////////////////////////////// -->
    
<!--// CAMERA SETTINGS // -->
    
<CAMERA_0>
        <
USECAMERA>1</USECAMERA>
        <
DEVICE>0</DEVICE>
        <
WIDTH>320</WIDTH>
        <
HEIGHT>240</HEIGHT>
        <
FRAMERATE>4</FRAMERATE>
    </
CAMERA_0>
    <!--
// NETWORK COMMUNICATION SETTINGS //-->
    
<NETWORK>
        <
LOCALHOST>127.0.0.1</LOCALHOST>
        <
TUIO>0</TUIO>
        <
TUIOPORT_OUT>3333</TUIOPORT_OUT>
        <
TUIOFLASHPORT_OUT>3000</TUIOFLASHPORT_OUT>
    </
NETWORK>
    <!--
// VIDEO SETTINGS // -->
    
<VIDEO>
        <
FILENAME>test_videos/RearDI.m4v</FILENAME>
    </
VIDEO>
    <!--
// BLOB SETTINGS // -->
    
<BLOBS>
        <
MAXNUMBER>100</MAXNUMBER>
    </
BLOBS>
    <!--
/////////////////////////////////////////

        
DO NOT EDIT THE VALUES BELOW
 
    
///////////////////////////////////////////// -->
    
<APPLICATION>
        <
TITLE>Community Core Visision</TITLE>
        <
VERSION>1.3.1</VERSION>
    </
APPLICATION>
    <
WINDOW>
        <
WIDTH>950</WIDTH>
        <
HEIGHT>600</HEIGHT>
    </
WINDOW>
    <
BOOLEAN>
        <
PRESSURE>0</PRESSURE>
        <
LABELS>1</LABELS>
        <
OUTLINES>1</OUTLINES>
        <
LEARNBG>0</LEARNBG>
        <
TUIO>0</TUIO>
        <
VMIRROR>0</VMIRROR>
        <
HMIRROR>1</HMIRROR>
        <
HIGHPASS>1</HIGHPASS>
        <
AMPLIFY>0</AMPLIFY>
        <
SMOOTH>1</SMOOTH>
        <
GPU>0</GPU>
        <
DYNAMICBG>0</DYNAMICBG>
        <
SNAPSHOT>0</SNAPSHOT>
        <
MINIMODE>0</MINIMODE>
        <
HEIGHTWIDTH>0</HEIGHTWIDTH>
        <
OSCMODE>0</OSCMODE>
        <
TCPMODE>0</TCPMODE>
        <
BINMODE>0</BINMODE>
        <
TRACKDARK>0</TRACKDARK>
        <
TRACKFINGERS>1</TRACKFINGERS>
        <
TRACKOBJECTS>0</TRACKOBJECTS>
        <
TRACKFIDUCIALS>1</TRACKFIDUCIALS>
        <
UNDISTORT>0</UNDISTORT>
        <
HORIZONTALINVERSE>1</HORIZONTALINVERSE>
        <
VERTICALINVERSE>1</VERTICALINVERSE>
    </
BOOLEAN>
    <
INT>
        <
MINMOVEMENT>0</MINMOVEMENT>
        <
MINBLOBSIZE>346</MINBLOBSIZE>
        <
MAXBLOBSIZE>100</MAXBLOBSIZE>
        <
BGLEARNRATE>19.145454</BGLEARNRATE>
        <
THRESHOLD>36</THRESHOLD>
        <
HIGHPASSBLUR>65</HIGHPASSBLUR>
        <
HIGHPASSNOISE>0</HIGHPASSNOISE>
        <
HIGHPASSAMP>76</HIGHPASSAMP>
        <
SMOOTH>2</SMOOTH>
        <
MINTEMPAREA>0</MINTEMPAREA>
        <
MAXTEMPAREA>0</MAXTEMPAREA>
    </
INT>
    <
FIDUCIAL>
        <
HIGHPASS>1</HIGHPASS>
        <
AMPLIFY>0</AMPLIFY>
        <
SMOOTH>1</SMOOTH>
        <
THRESHOLD>20</THRESHOLD>
        <
HIGHPASSBLUR>21</HIGHPASSBLUR>
        <
HIGHPASSNOISE>1</HIGHPASSNOISE>
        <
HIGHPASSAMP>0</HIGHPASSAMP>
        <
SMOOTHVALUE>1</SMOOTHVALUE>
    </
FIDUCIAL>
</
CONFIG>

cam actived:
?ACT=28&fid=19&aid=7026_qabvEw5vJrwpAvQPOaQ6

File Attachments
4cam.PNG  (File Size: 27KB - Downloads: 1086)
 Signature 

http://www.mt2a.com

Multi-touch Solution and Equipment Supplier!

Profile
 
 
   
6 of 24
6