Can’t run CCV in notebooks
Posted: 07 October 2011 07:27 AM   [ Ignore ]
Avatar
Rank
Joined  2011-10-06
Total Posts:  2
New Member

Hi,

I’ve installed CCV 1.4.0 in a desktop and in a notebook, both running Kubuntu 11.04.

In the desktop it works fine and these are its console messages:

TreeIdMap loaded succesfully from ‘data/all.trees’.
device 0: /dev/video0: UVC Camera (046d:0990)
Linux Camera Mode
Asked for 320 by 240 - actual size is 320 by 240
Camera(s)/Video Initialised…
Calibration: 613.000000, 54.000000
Calibration: 425.000000, 40.000000
Calibration: 211.000000, 37.000000
Calibration: 17.000000, 43.000000
Calibration: 605.000000, 188.000000
Calibration: 418.000000, 184.000000
Calibration: 212.000000, 181.000000
Calibration: 21.000000, 181.000000
Calibration: 588.000000, 320.000000
Calibration: 411.000000, 325.000000
Calibration: 217.000000, 324.000000
Calibration: 35.000000, 317.000000
Calibration: 567.000000, 430.000000
Calibration: 401.000000, 442.000000
Calibration: 219.000000, 440.000000
Calibration: 47.000000, 423.000000
Calibration is setup!
Starting in standalone mode…
Starting in full mode…
Community Core Vision is setup!
Vision module has exited!

But in the notebook (a Dell Inspiron 1525) the following error occurs:

TreeIdMap loaded succesfully from ‘data/all.trees’.
device 0: /dev/video0: Laptop Integrated Webcam
device 1: /dev/video1: UVC Camera (046d:0990)
OF_ERROR: ofGstUtils: error getting device data: no element “v4l2src”
Segmentation fault

I tried it in another notebook (ACER) with the same result.

I couldn’t find anything in Google. Any hint?

Thanks

Profile
 
 
Posted: 09 October 2011 12:12 PM   [ Ignore ]   [ # 1 ]
Avatar
Rank
Joined  2011-10-06
Total Posts:  2
New Member

By the way, the following command works fine in my notebook:

gst-launch v4l2src xvimagesink

so v4l2src is working fine itsellf.

Profile
 
 
Posted: 25 January 2016 12:55 AM   [ Ignore ]   [ # 2 ]
Rank
Joined  2016-01-24
Total Posts:  1
New Member

I know this is an incredibly late response, but I recently started using this for a project I am working on.

It turns out that this is true. I am running Mint 17 on an old Dell Latitude E6410 Laptop as well as a Dell T-5500 desktop. It works great on the Desktop. The same error persists for the laptop.

My solution is to run CCV on a windows box connected over a LAN and just connect to the IP-Port. I think that will be the best way of getting past the error for now.

Best,

Aaron

Profile