3 of 43
3
Sony PS3Eye running under Windows!!! **UPDATED** Driver v3.0.0.0825 (Selectable Capture Frame Rate and Resolution)
Posted: 06 September 2008 09:11 PM   [ Ignore ]   [ # 31 ]
Rank
Joined  2008-09-06
Total Posts:  2
New Member

I hate to be rude but this doesn’t seem to work.  At least for me it seems to purely only work within the test application.  I can not get it to show up in any other application.  I was attempting to use this for broadcasting purposes over the internet.  However it doesn’t even show up as a device.

It also seems to have stopped working even in that application right now.

Profile
 
 
Posted: 07 September 2008 01:58 AM   [ Ignore ]   [ # 32 ]
Avatar
RankRankRank
Joined  2008-05-08
Total Posts:  342
Sr. Member
Volomon - 06 September 2008 09:11 PM

I hate to be rude but this doesn’t seem to work.  At least for me it seems to purely only work within the test application.  I can not get it to show up in any other application.  I was attempting to use this for broadcasting purposes over the internet.  However it doesn’t even show up as a device.

It also seems to have stopped working even in that application right now.

I think you misunderstood my post. The camera is not exposed to Windows as a video source. The test app is accessing the camera directly. In future I will expand the camera controls and wrap it all in a dll that can be loaded into TouchLib and other frameworks.
Since the camera access API will be well defined, you’ll be able to use it in your application as well.

~Alex

 Signature 

Computing is not about computers any more.  It is about living!

Code Laboratories
CL Studio Live - Video like never before
CL Eye Platform SDK

Profile
 
 
Posted: 07 September 2008 02:00 AM   [ Ignore ]   [ # 33 ]
Rank
Joined  2008-09-04
Total Posts:  44
New Member

Getting this error when running the ps3test.  “The application has failed to start because its side-by-side configuration is incorrect.  Please see the application event log for more details.”

Profile
 
 
Posted: 07 September 2008 02:37 AM   [ Ignore ]   [ # 34 ]
Rank
Joined  2008-09-06
Total Posts:  2
New Member
AlexP - 07 September 2008 01:58 AM

Volomon - 06 September 2008 09:11 PM
I hate to be rude but this doesn’t seem to work.  At least for me it seems to purely only work within the test application.  I can not get it to show up in any other application.  I was attempting to use this for broadcasting purposes over the internet.  However it doesn’t even show up as a device.

It also seems to have stopped working even in that application right now.

I think you misunderstood my post. The camera is not exposed to Windows as a video source. The test app is accessing the camera directly. In future I will expand the camera controls and wrap it all in a dll that can be loaded into TouchLib and other frameworks.
Since the camera access API will be well defined, you’ll be able to use it in your application as well.

~Alex

Dang :( I was hoping for that miracle.  Oh well thx for working on it and I wish you god like speed.

Profile
 
 
Posted: 08 September 2008 07:39 AM   [ Ignore ]   [ # 35 ]
Rank
Joined  2007-06-01
Total Posts:  54
New Member

Here’s (probably) the source code for the 640x480 @ 30fps version https://jim.sh/svn/jim/devl/playstation/ps3/eye/test/ (haven’t talked to AlexP about it). This version works in Linux using libusb.

 Signature 

Sebastian Hartman

Profile
 
 
Posted: 08 September 2008 10:31 AM   [ Ignore ]   [ # 36 ]
Rank
Joined  2007-07-25
Total Posts:  36
New Member

Alex many thanks for this drive.

Anybody knows if this works in XP?

Profile
 
 
Posted: 08 September 2008 01:29 PM   [ Ignore ]   [ # 37 ]
Avatar
RankRankRankRank
Joined  2007-09-18
Total Posts:  882
Moderator

hi, ps3 eyes !

i installed successfully the Alex driver on XP ,
it was quite harsh at the beginning , the first tests failed , the video was freezing after a few seconds ( 1 to 4).
So I tested each port from bad issues to bad issue and reinstalling the driver for each one .

after installing the driver on every ports , it finally works .

Great job , Alex P !

Can’t wait for your further improvements !

Image Attachments
test2.jpg
 Signature 

How many touches can you simultaneously perform ? 
Coming soon : EveryWall MT / Multi LaserPointers / MT SMS Wall
le WIKI en Fran├žais

Profile
 
 
Posted: 08 September 2008 04:42 PM   [ Ignore ]   [ # 38 ]
Avatar
RankRankRank
Joined  2008-05-08
Total Posts:  342
Sr. Member
iloveanime213 - 07 September 2008 02:00 AM

Getting this error when running the ps3test.  “The application has failed to start because its side-by-side configuration is incorrect.  Please see the application event log for more details.”

You might not have the Microsoft Visual C++ 2005 Redistributable Package installed on your system.
It is available on the Microsoft site. Here is the link for the 32-bit version:
http://www.microsoft.com/downloads/details.aspx?FamilyID=32bc1bee-a3f9-4c13-9c99-220b62a191ee&DisplayLang=en
and for the 64-bit version:
http://www.microsoft.com/downloads/details.aspx?familyid=90548130-4468-4BBC-9673-D6ACABD5D13B&displaylang=en

Hope it helps

~Alex

 Signature 

Computing is not about computers any more.  It is about living!

Code Laboratories
CL Studio Live - Video like never before
CL Eye Platform SDK

Profile
 
 
Posted: 08 September 2008 04:44 PM   [ Ignore ]   [ # 39 ]
Avatar
RankRankRank
Joined  2008-05-08
Total Posts:  342
Sr. Member
jimihertz - 08 September 2008 01:29 PM

hi, ps3 eyes !

i installed successfully the Alex driver on XP ,
it was quite harsh at the beginning , the first tests failed , the video was freezing after a few seconds ( 1 to 4).
So I tested each port from bad issues to bad issue and reinstalling the driver for each one .

after installing the driver on every ports , it finally works .

Great job , Alex P !

Can’t wait for your further improvements !

I’m glad it works on XP. Thank you jimihertz for testing it out.
Will keep you posted with new updates.

~Alex

 Signature 

Computing is not about computers any more.  It is about living!

Code Laboratories
CL Studio Live - Video like never before
CL Eye Platform SDK

Profile
 
 
Posted: 09 September 2008 01:02 PM   [ Ignore ]   [ # 40 ]
Rank
Joined  2008-08-05
Total Posts:  25
New Member

Still getting “application cannot start because application configuration is incorrect” errors when launching the tester exe.

I have visual studio 2008 installed as well as c++ runtimes. Followed the instructions for the install to the letter.

Jimihertz do you have anything special for the xp install to get it to start working properly?

Thx

Profile
 
 
Posted: 09 September 2008 03:08 PM   [ Ignore ]   [ # 41 ]
Avatar
RankRankRank
Joined  2008-05-08
Total Posts:  342
Sr. Member
Throgors - 09 September 2008 01:02 PM

Still getting “application cannot start because application configuration is incorrect” errors when launching the tester exe.

I have visual studio 2008 installed as well as c++ runtimes. Followed the instructions for the install to the letter.

Jimihertz do you have anything special for the xp install to get it to start working properly?

Thx

Throgors, do you have VC++ 2005 runtimes installed?

 Signature 

Computing is not about computers any more.  It is about living!

Code Laboratories
CL Studio Live - Video like never before
CL Eye Platform SDK

Profile
 
 
Posted: 09 September 2008 04:02 PM   [ Ignore ]   [ # 42 ]
Rank
Joined  2008-08-05
Total Posts:  25
New Member

Yes I do.

Dependency walker reports this

Error: The Side-by-Side configuration information for “c:\download\touch\ps3eyetest\PS3EYETEST.EXE” contains errors. This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem (14001).
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

the warning can be ignored of course.

Here is control panel with installed runtime. As well as c++ itself.
installed.jpg

It doesnt have to do with your application though, as touchlib config app no longer works now either.

I reinstalled XP with SP2 on a new machine, installer 3.1 , net 3.5, c++ redistributable, and could not get touchlib or ps3 exe working, same error.

Profile
 
 
Posted: 10 September 2008 01:25 AM   [ Ignore ]   [ # 43 ]
Rank
Joined  2008-08-05
Total Posts:  25
New Member

Got touchlib working again, had to move some DLL’s into the folder with it, only .net 3.5 and c++ runtimes installed.

What path is your app looking for the CRT DLL’s in?  ( &#xsy;stemroot%\windows\WinSxS\???  )

I put all dll’s from winSxs folder into folder with exe, no go, dependency walker was happy though =\

I knowticed XP is naming the folders in winsxs really long obsurd filenames, might be causing the issues.

Profile
 
 
Posted: 10 September 2008 02:04 AM   [ Ignore ]   [ # 44 ]
Rank
Joined  2008-08-05
Total Posts:  25
New Member

Dude I friggen got it.

God damned microsoft is the most idiodic company sometimes i swear..

The c++ runtimes installer they provide is crap, I used the one provided with the USBTester from jungo, and it works AWESOME!!!

50FPS just like you said.

Awesome work man.

Are there plans on making the 320x240 at 120fps for your touchlib implementation?

I so cant wait to try this on the screen, my logitech webcam was slackin big time.

Got the distributable package out of the installer and posted it on my site for download
http://dev-x.org/vcredist_x86.rar

Profile
 
 
Posted: 10 September 2008 01:17 PM   [ Ignore ]   [ # 45 ]
Avatar
RankRankRank
Joined  2008-05-08
Total Posts:  342
Sr. Member
Throgors - 10 September 2008 02:04 AM

Dude I friggen got it.

God damned microsoft is the most idiodic company sometimes i swear..

The c++ runtimes installer they provide is crap, I used the one provided with the USBTester from jungo, and it works AWESOME!!!

50FPS just like you said.

Awesome work man.

Are there plans on making the 320x240 at 120fps for your touchlib implementation?

I so cant wait to try this on the screen, my logitech webcam was slackin big time.

Got the distributable package out of the installer and posted it on my site for download
http://dev-x.org/vcredist_x86.rar

Throgors thanks!
I’m glad you got it working. I looked into the dll issue as well.
The reason why it didn’t work for you might have been that you were installing VC++ 2005 redist where in fact you need VC++ 2005 SP1 redist.
I agree with you Microsoft should have some kind mechanism in place for detecting the version that is needed and directing you to the right place for download.

You can download the correct redist from the following links:

x86 version: http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=en
x64 version: http://www.microsoft.com/downloads/details.aspx?familyid=EB4EBE2D-33C0-4A47-9DD4-B9A6D7BD44DA&displaylang=en

BTW, I posted the updated PS3EyeTest app that captures 640x480 at 60fps now.

~Alex

 Signature 

Computing is not about computers any more.  It is about living!

Code Laboratories
CL Studio Live - Video like never before
CL Eye Platform SDK

Profile
 
 
   
3 of 43
3