config works partially but demo apps don’t - please help!!! SOLVED
Posted: 03 November 2008 05:00 AM   [ Ignore ]
Rank
Joined  2008-11-03
Total Posts:  16
New Member

Hi folks!!

As I am new to the forum first of all a friendly “hello!” from Austria to everyone =) I am amazed by this program and by the idea of building my own multitouch screen, you guys are genius!!!

Unfortuantely I am not as much a genius as you are, so I hope you might be able to help me a little out. I discovered Touchlib this weekend and instantly tried it out. I am right now running MTmini, having a box with the webcam inside, covered with a glas and paper, trying to get the pictures on my laptop screen. Here is the problem I experience:

When I do the first part of the configuration, this is the result that I get (please refer to attached screenshot). Since I read almost every forum post in question, I think the result in rectify6 is quite good. Am I right?
Okay, so I have this and press enter to make the second part of the config appear. here it gets a little sketchy: when I move my finger now on the glas, the mousepointer moves surrounded by a violet rectangle. BUT even if I hold my finger steady, the mouse pointer “jumps” around nervously. And when I move my finger lets say from up to down, the mous pointer also moves up-down, but jumping left-right aswell. If I press “c” to start the configuration, its really hard to hit the indicated points. Mostly the program recognizes the point as touched and moves to the next, without me knowing why it just happend. I have no control over it, i just move my fingers somehow all over the glas to cover the entire area. When I am finished, I press escape and start the smoke demo app.
Here again the same problem: when I move my finger on the glas lets say from up to down, the detected blobb(s) also move up-down, but jumping left-right aswell, giving me 3-5 blobbs for only one finger on the glas. I hope I made clear what I mean, to make sure I attached another screenshot. i had one finger on the plate, but it detected 3 bobbs at the same time jumping around.

EDIT: I found out now, that in the touch-listener the “weight” of all my touches is zero. Can this be the problem? How to solve it?

I hope you can give me a hint what to improve,
best regards and thanks in advance for your help
albinoblacksheep

Image Attachments
touchlib.jpgsmoke.jpgtouchlistener.JPG
Profile
 
 
Posted: 03 November 2008 06:51 AM   [ Ignore ]   [ # 1 ]
Rank
Joined  2008-11-03
Total Posts:  16
New Member

SOLVED!

okay guys I figured it out!!
In case anyone experiences the same problem, here the solution:
You really have to do the calibration carefully (the part with the black screen and the crosses). Why it didnt work is because I didn’t realize that actually only a tapping is taken as a valid point.

Wrong idea: move the finger on the plate without taking it off the plate to the marked cross
Right idea: move the finger NOT TOUCHING THE PLATE in direction of the cross, put down your finger and this “click” is detected. So what is important is the sequence finger not on plate => finger on plate => finger off the plate again. This sequence is detected and the coordinates of this touch is asigned to the currently marked cross. Dont slide the finger across the plate! In case of missdetection, press ‘r’ to go back to the desired point you wanna label next.

Doing this for every point and the whole thing rocks like the Rolling Stones ;o)
Have fun!!!
See you when I have the next question haha.
tschau

Profile