9 of 9
9
[Tutorial] PS3 Eye Working on Linux
Posted: 08 November 2009 09:05 PM   [ Ignore ]   [ # 121 ]
Rank
Joined  2009-11-08
Total Posts:  6
New Member
yomat - 08 November 2009 09:04 PM

Seems nice,

I don’t know why it doesn’t work good for me (a lot flickering, low framerate and some freezing ??? the same with kaswy’s original drivers).

thx

In what programs? guvcview?

Profile
 
 
Posted: 08 November 2009 09:38 PM   [ Ignore ]   [ # 122 ]
Rank
Joined  2009-07-09
Total Posts:  4
New Member

bear24rw,

Yep, that’s it, in guvcview. A strange side effect of playing with parameters is a strong decrease of fps.
Mplayer give me the same (temporary fps deceleration, flickering) and a curious Frame too small! (608624<614400) Wrong format?.
VLC give me a core dumped !!!

I’ve just try kaswy’s new patch installation yesterday and all the effects were almost identical for guvcview, and vlc (mplayer just gave me a black screen !!)

I think these effects mainly come from my computer hardware/ubuntu config (an old P4 and a lot of upgrades to new release) because I’ve already and successfully used Kaswy drivers on a poor dell mini 9.

Does anybody have got the key ? the same effects ?

Profile
 
 
Posted: 21 December 2009 11:04 AM   [ Ignore ]   [ # 123 ]
Rank
Joined  2009-12-15
Total Posts:  14
New Member

After i follow http://kaswy.free.fr/?q=node/49 , now tbeta able to detect my built-in webcam on Fedora 12. Thanks

Profile
 
 
Posted: 26 December 2009 09:19 AM   [ Ignore ]   [ # 124 ]
Rank
Joined  2009-12-26
Total Posts:  1
New Member

I found this driver (and page) a couple days ago, and got to the verge of my ps eye working and ran into a brick wall… after trying several kernels and multiple compiles and removals of the driver, the brick wall is still there.

No problem compiling; and all v4l2 apps detect the cam. They can detect the settings, stream type, etc. But not one app can actully demux the video! As in this teminal output:

xawtv:

v4l2oopsselect timeout
libv4l2
error dequeuing bufInput/output error
v4l2
readInput/output error

luvcview:

SDL information:
  
Video driverx11
  A window manager is available
Device information
:
  
Device path:  /dev/video0
Stream settings
:
  
Frame formatYUYV (MJPG is not supported by device)
  
Frame size:   640x480
  Frame rate
:   30 fps
Unable to dequeue buffer
Input/output error
Error grabbing
Cleanup done
Exiting ...

mplayer:

Playing tv://.
TV file format detected.
Selected driverv4l2
 name
Video 4 Linux 2 input
 author
Martin Olschewski <olschewski@zpr.uni-koeln.de>
 
commentfirst try, more to come ;-)
Selected deviceUSB Camera-B4.04.27.1
 Capabilites
:  video capture  read/write  streaming
 supported norms
:
 
inputsov534;
 
Current input0
 Current format
YUYV
tv
.cnorm_from_string(pal): Bogus norm parametersetting default.
v4l2ioctl enum norm failedInvalid argument
Error
Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
v4l2: ioctl query control failed: Invalid argument
v4l2: ioctl query control failed: Invalid argument
v4l2: ioctl query control failed: Invalid argument
v4l2: ioctl query control failed: Invalid argument
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: Packed YUY2)
VDec: using Packed YUY2 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Packed YUY2 
Selected video codec: [rawyuy2] vfm: raw (RAW YUY2)
==========================================================================
Audio: no sound
Starting playback...
v4l2: select timeout
v4l2: select timeout ??% ??,?% 0 0 
v4l2: select timeout ??% ??,?% 0 0 
v4l2: select timeout ??% ??,?% 0 0 
...
...

vlc’s timeout is phrased

v4l2 demux errorFailed to wait (VIDIOC_DQBUF)

I first installed the driver under 2.6.24.something, upgraded to intrepid (2.6.27-16), now Jaunty with 2.6.29.6 and a couple of 2.6.28’s still in the grub menu. All have produced the same basic timout results but worked fine otherwise. Haven’t been able to display one frame of video, but managed some badly distorted audio in Skype one time.

I’ve tried read method as well as mmap.

This seems like a v4l2 problem rather than a driver problem

<> VIDIOC_DQDBUF is defined in v4l2-ioctl.c… looking there

<> “select()” as a v4l2 control apparently is supposed to timeout and return a failure, to block freezes… but I don’t know what that timeout interval is or how to change it. Unless it’s the CONTROL_TIMEOUT in ov534.c mentioned in an earlier post. There is supposedly a manual page for select() but I can’t find it. Raising control_timeout didn’t change anything

<> can’t get beyond the dqbuf failure with kaswy driver, turning to the mercurial one… it seems to have been patched pretty frequently, maybe there are some control options

[essentially solved] defect in usb controller.

But the driver with ubuntu Karmic (2.6.31) seems to work better than the MT one. Have any control options been added to the one that come with the kernel… can’t see even a videomode option

Profile
 
 
Posted: 10 February 2010 08:44 PM   [ Ignore ]   [ # 125 ]
Avatar
Rank
Joined  2010-01-17
Total Posts:  53
New Member

Sorry to bother everyone by bumping an old topic, but I just installed the latest debian-testing, and I can’t get gspca-ov534 to work.
I have followed kawsy’s blog instructions (and bear24rw’s too) but I still get the infamous

multistuff:/usr/src/linux# uname -r
2.6.32-trunk-686

filename
:       /lib/modules/2.6.32-trunk-686/kernel/drivers/media/video/gspca/gspca_ov534.ko
license
:        GPL
description
:    GSPCA/OV534 USB Camera Driver(kaswy mod for MT use V0.5 bear24rw patch V0.1)
author:         Antonio Ospite <ospite@studenti.unina.it>
alias:          usb:v1415p2000d*dc*dsc*dp*ic*isc*ip*
depends:        gspca_main,usbcore
vermagic
:       2.6.32 SMP mod_unload modversions 686 
parm
:           videomode: = xx //Set the videomode(see doc) (int)
parm:           autogain: = [0|1] //Autogain (agc,aec,awb) (bool)
parm:           gain: = [0..63] //main gain (int)
parm:           awb: = [0|1] //Auto White Balance (bool)
parm:           exposure: = [0..255] //Exposure (int)
parm:           brightness: = [0..255] //Brightness (int)
parm:           contrast: = [0..255] //Contrast (int)
parm:           redblc: = [0..255] //Red Balance (int)
parm:           blueblc: = [0..255] //Blue Balance (int)
parm:           hue: = [0..255] //Hue (int)
parm:           sharpness: = [0..63] //Sharpness (int)
parm:           vflip: = [0|1] //Vertical flip (bool)
parm:           hflip: = [0|1] //Horizontal mirror (bool)

multistuff:/usr/src/linux# modprobe gspca-ov534 videomode=10
FATALError inserting gspca_ov534 (/lib/modules/2.6.32-trunk-686/kernel/drivers/media/video/gspca/gspca_ov534.ko): Unknown symbol in module, or unknown parameter (see dmesg)

[ 1634.662837] gspca_ov534disagrees about version of symbol gspca_frame_add
[ 1634.662844] gspca_ov534
Unknown symbol gspca_frame_add
[ 1634.663420] gspca_ov534
disagrees about version of symbol gspca_dev_probe
[ 1634.663423] gspca_ov534
Unknown symbol gspca_dev_probe

Anyone knows how to fix that ? Just to let you know : I installed a Debian with XFCE because I’m on an old dell inspiron computer and I wanted to have the smallest OS possible just for multitouch tracking. But I’m not really good with Linux :/

 Signature 

LLP + LCD Build Log

Profile
 
 
Posted: 13 February 2010 01:08 PM   [ Ignore ]   [ # 126 ]
Avatar
Rank
Joined  2010-01-17
Total Posts:  53
New Member

Well, I finally succeeded in getting the PS3 eye to work under Linux using kawsy’s driver (v0.5) and I think that the 2.6.32 kernel is what was making it fail
I installed xubuntu 9.10 (uname -r > 2.6.31-14-generic) and everything went superfine, I can finally use the videomode options etc…
Thanks Kaswy =)

 Signature 

LLP + LCD Build Log

Profile
 
 
Posted: 17 February 2010 02:52 PM   [ Ignore ]   [ # 127 ]
Avatar
Rank
Joined  2010-01-17
Total Posts:  53
New Member

Just to let you know : modifying the .patch from kaswy in order to make it work with the unicap 0.9.8 lib is fine. However you still must have to use the 2.6.31 linux kernel to get the gspca-ov534 module to work.
Cheers

 Signature 

LLP + LCD Build Log

Profile
 
 
Posted: 11 March 2010 06:53 PM   [ Ignore ]   [ # 128 ]
Rank
Joined  2009-05-11
Total Posts:  6
New Member

Hello everyone,

I am trying to install kaswy’s latest driver (0.5) in fedora 11, but get the following errors:

CC [M] /home/wbrent/gspca-ps3eyeMT/v4l/au0828-core.o
CC [M] /home/wbrent/gspca-ps3eyeMT/v4l/au0828-i2c.o
CC [M] /home/wbrent/gspca-ps3eyeMT/v4l/au0828-cards.o
In file included from /home/wbrent/gspca-ps3eyeMT/v4l/dmxdev.h:34,
from /home/wbrent/gspca-ps3eyeMT/v4l/au0828.h:35,
from /home/wbrent/gspca-ps3eyeMT/v4l/au0828-cards.c:23:
/home/wbrent/gspca-ps3eyeMT/v4l/compat.h:396: error: redefinition of ‘usb_endpoint_type’
include/linux/usb/ch9.h:376: note: previous definition of ‘usb_endpoint_type’ was here
make[3]: *** [/home/wbrent/gspca-ps3eyeMT/v4l/au0828-cards.o] Error 1
make[2]: *** [_module_/home/wbrent/gspca-ps3eyeMT/v4l] Error 2
make[2]: Leaving directory `/usr/src/kernels/2.6.30.10-105.2.23.fc11.x86_64’
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/wbrent/gspca-ps3eyeMT/v4l’
make: *** [all] Error 2

any suggestions on how to overcome this?

I have the kenerl source and headers up to date and coinciding with my .version file,

best,

Jaime

Profile
 
 
Posted: 16 July 2010 04:35 PM   [ Ignore ]   [ # 129 ]
Rank
Joined  2010-07-16
Total Posts:  1
New Member

I’m working on some software to track eye movement using opencv and a ps3 eye camera.
I had some trouble, but was able to get things working after some tinkering, but didn’t really find anything on the internet that could help, so I figured this seems to be the best spot to post.

I could capture the camera fine, but the image was actually multiple images over lapping each other.  It was ugly.  I had no idea what to do, but it turns out, this is because opencv and v4l don’t handle the ps3eye’s double buffering well, at least not out of the box.  Fedora12 seems to deal with it no problem, but ubuntu 10 has some issues, so I’d assume the same issue is with any debian based system.

This is how I fixed the image:

//Causes Errors:
frame cvQueryFramecapture );

//Fix:
cvGrabFramecapture );
frame cvQueryFramecapture );

I hope that helps some people - it frustrated me for four days.

Take care,
-Alex

Profile
 
 
Posted: 23 July 2010 06:54 AM   [ Ignore ]   [ # 130 ]
Avatar
Rank
Joined  2010-07-22
Total Posts:  1
New Member

Hi,

I’m an Arch linux user and would like to get my PS3 Eye working with my system. Arch is at kernel version 2.6.34. Is there any patches that would be compatible or would I need to downgrade my kernel to 2.6.31 to get these to work?

I do get a working driver of sorts with the native kernel. Only the brightness appears to be way off, see:

Image capture from PS3 Eye Kernel 2.6.34-Arch native module

I have a thread where I’ve tried some of your patches with the 2.6.34 kernel on the Arch linux forums.

Profile
 
 
Posted: 01 August 2010 06:40 PM   [ Ignore ]   [ # 131 ]
Rank
Joined  2010-05-22
Total Posts:  16
New Member

Im using 2.6.33-gentoo kernel and i can’t seam to get it to work, i have tried the precompiled version and the patch http://kaswy.free.fr/?q=en/node/53 doesn’t match the kernel. If i post the c file could some one whit i bit more knowledge then me patch it for me?

Edit: never mind it worked whit the driver out of box. Just hadn’t started hotplug rasberry

Profile
 
 
   
9 of 9
9
 
‹‹ Why 5?      Binoculars idea for camera ››