7 of 9
7
[Tutorial] PS3 Eye Working on Linux
Posted: 24 April 2009 04:16 PM   [ Ignore ]   [ # 91 ]
Rank
Joined  2009-03-10
Total Posts:  22
New Member

Have you rebooted after installing the driver?  Those errors are because it is trying to load Kaswy’s driver (using a newer/different build of the gspca framework) with the older gspca kernel module, and the symbol tables do not match.  Usually, rebooting gets the old one out of memory.  You can try manually unloading it and running `depmod -a` also.

Profile
 
 
Posted: 24 April 2009 04:26 PM   [ Ignore ]   [ # 92 ]
Rank
Joined  2009-04-24
Total Posts:  7
New Member

YEAH!!!!

After reboot it’ OK!!!

Thanks mattty!!! Thanks all!!! I’m so happy and feel light!!!

Now I try in VLC or somthing else… but my nightmare is gone!

I suggest to modify the tutorials with this (for the newbies like me)

CIAOOOOOOOO!

Profile
 
 
Posted: 24 April 2009 04:29 PM   [ Ignore ]   [ # 93 ]
Rank
Joined  2009-03-10
Total Posts:  22
New Member

I like using mplayer to test the camera performance, since VLC buffers the video alot.

I invoke mplayer to watch the camera like this:
mplayer -vo xv tv:// -tv driver=v4l2:width=640:height=480:fps=30:device=/dev/video0

Profile
 
 
Posted: 24 April 2009 04:36 PM   [ Ignore ]   [ # 94 ]
Rank
Joined  2009-04-24
Total Posts:  7
New Member

While downloading VLC I’ve tried with Ekiga… and it WORKS!!! double yeah!!!

Thanks mattty… I’ll download mplayer too.

CIAO… now I go to sleep… here in Italy it’s 23:30 and tomorrow there’s a great festivity: the liberation day! Night!!!!

Update:
Downloaded and installed mplayer: all works great now (tried 320x240 100 fps).
Now I’ll wait for the tbeta ps3 eye linux patch!

Profile
 
 
Posted: 25 April 2009 07:44 PM   [ Ignore ]   [ # 95 ]
Rank
Joined  2009-03-10
Total Posts:  22
New Member

I ported the patch linked on the prior page to the code in the touchlib svn right now (revision 400), and touchlib runs without crashing now.  It is super sluggish and freezes/resumes very often.  Anyone had this happen?

Profile
 
 
Posted: 27 April 2009 09:29 AM   [ Ignore ]   [ # 96 ]
RankRank
Joined  2008-12-10
Total Posts:  209
Member

I’m seeing the same thing matty - I think.

configapp (the calibration app that shows you the camera video feed in X number of windows) is extremely slow, on the order of 1fps.  I haven’t noticed it freeze/resume, but with that kind of responsiveness it’s hard to tell.

The other apps that come with touchlib seem to work just fine ( smoke demo, etc ) - so the touchlib library is reading the camera feed just fine, this leads me to believe the problem is a display issue (software rendering vs. XVideo extension), or a timing issue in the CV capture code

It’s usable if you’re patient enough to get your camera calibrated well, but that step is nigh impossible for me at the moment.

[edit]
Just occurred to me that the actual touch calibration screen (with the red X’s) shows a debug window of the video feed, and that seems to be displaying at full FPS, the trouble is definitely something to do with touchlib’s display of the several video feed windows.

 Signature 

22” LLP-LCD ftw
TUIO Smoke (Windows / Linux) - http://projects.edencomputing.com/projects/tuiosmoke

Profile
 
 
Posted: 27 April 2009 11:08 AM   [ Ignore ]   [ # 97 ]
Rank
Joined  2009-04-24
Total Posts:  7
New Member

hi,

I too have problems here with TouchLib… freeze and close after few seconds…

Not tested much though.

PS: I’ve got problem with patching ‘cause it tells me 2 Fails applying the patch… someone can help?

Thanks all. Ciao!!!

Profile
 
 
Posted: 27 April 2009 01:15 PM   [ Ignore ]   [ # 98 ]
Rank
Joined  2009-03-10
Total Posts:  22
New Member

I pulled r393 from SVN and patched that, works fine.

Profile
 
 
Posted: 13 May 2009 04:19 PM   [ Ignore ]   [ # 99 ]
Rank
Joined  2009-05-12
Total Posts:  4
New Member

I have the P3 Eye working on my ubuntu box!!! Wooo Hooo!!! Great!!!
Thanks for the driver and tutorial!!!

When will we be able to use it in CCV??? I run CCV and it runs fine just doesn’t pull in video input from my ps3 eye.
I have it working on windows xp on my laptop and CCV but the graphics capabiliies of my laptop are not that great so the
blob tracking is herky jerky at best - I have an Nvidia 8600 and Dual core on my ubuntu box and it is very fast but no input
from PS3 Eye.

Thanks for all of the hard work so far, just a little further to go!!!

Profile
 
 
Posted: 13 May 2009 05:18 PM   [ Ignore ]   [ # 100 ]
Rank
Joined  2009-04-24
Total Posts:  7
New Member

Hi JP S,

i’m happy for you!

I’ve tried on Ubuntu 8.04 with no luck - the image is very strange in Pure Data (I need 8.04 ‘cause I use Pure Data and GEM and I can’t install both on 9.04)

I hope now that with the source code provided from CCV crew (am I right?) someone skilled patch CCV to use PS3 eye. I too have an old PC with XP and it’s working but on my main PC I use only Ubuntu and so I need CCV + Ubuntu + PS3 eye.

Thanks a lot for the work… I hope, hope , hope… bye

Profile
 
 
Posted: 15 May 2009 11:24 AM   [ Ignore ]   [ # 101 ]
Rank
Joined  2009-05-12
Total Posts:  4
New Member

OK I don’t know what I did but I NOW HAVE MY PS3 EYE WORKING WITH CCV!!!! I have installed several things.....

unicap and attempted to compile touchlib with didn’t make install. But it is working perfectly at 20 fps!!!!

WOW!!!

Profile
 
 
Posted: 16 May 2009 07:16 AM   [ Ignore ]   [ # 102 ]
Rank
Joined  2009-05-16
Total Posts:  1
New Member
JP S - 15 May 2009 11:24 AM

OK I don’t know what I did but I NOW HAVE MY PS3 EYE WORKING WITH CCV!!!! I have installed several things.....

unicap and attempted to compile touchlib with didn’t make install. But it is working perfectly at 20 fps!!!!

WOW!!!

Can you explain it a little bit more exactly ? grin

i’m also trying to get ccv with ps3 eye to work…

thanks

Profile
 
 
Posted: 29 June 2009 06:19 AM   [ Ignore ]   [ # 103 ]
Rank
Joined  2009-05-11
Total Posts:  6
New Member

Hi all, I am new in this group,

I am trying to get the ps3eye to work on fc8 and think I have a version problem as stated in a previous message:

Martin Kaltenbrunner - 11 February 2009 03:49 AM

Hello, I just did that as well.
You need to edit the file “.version” and change the build version to 11.

when I run make in the latest version of the driver (0.5) I get:

[root@maquina gspca-ps3eyeMT]# make
make -C /home/joliverl/Desktop/gspca-ps3eyeMT/v4l
make[1]: Entering directory `/home/joliverl/Desktop/gspca-ps3eyeMT/v4l’
Updating/Creating .config
Preparing to compile for kernel version 2.6.26
File not found: /lib/modules/2.6.26.8-57.fc8/build/.config at ./scripts/make_kconfig.pl line 32, <IN> line 4.
make[1]: *** No rule to make target `.myconfig’, needed by `config-compat.h’.  Stop.
make[1]: Leaving directory `/home/joliverl/Desktop/gspca-ps3eyeMT/v4l’
make: *** [all] Error 2

Could someone confirm it is the same problem?
I can’t find the .version file. How could i solve this?

thanks,

Jaime

Profile
 
 
Posted: 29 June 2009 01:50 PM   [ Ignore ]   [ # 104 ]
Rank
Joined  2009-03-10
Total Posts:  22
New Member

Do you have your kernel source installed?

Profile
 
 
Posted: 29 June 2009 02:00 PM   [ Ignore ]   [ # 105 ]
Rank
Joined  2008-12-31
Total Posts:  37
New Member

First off, what is the name of your kernel (’uname -r’ to print it out)? The file referenced is “gspca-ps3eyeMT/v4l/.version”. Open your driver files, go into the “v4l” folder, right click and select show hidden files (CTRL+H for Nautilus). Changing the file is fairly self-explanatory once you have the proper kernel name.

Profile
 
 
   
7 of 9
7
 
‹‹ Why 5?      Binoculars idea for camera ››